Free Republic
Browse · Search
News/Activism
Topics · Post Article

To: TheBattman
While I am no MS fan, is Windows the only OS that throws a blue screen when things go wrong?

In the Unix world, it's called a kernel panic, after the name of the privileged function that is called to take the system down:

PANIC(9)		 BSD Kernel Developer's Manual		      PANIC(9)

NAME
     panic -- bring down system on fatal error


SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     void
     panic(const char *fmt, ...);

DESCRIPTION
     The panic() function terminates the running system.  The message fmt is a
     printf(3) style format string.  The message is printed to the console and
     the location panicstr is set to the address of the message text for
     retrieval from the OS core dump.

     If the kernel debugger is installed control is passed to it, otherwise an
     attempt to save a core dump of the OS to a configured dump device is
     made.

     If panic() is called twice (from the disk sync routines, for example) the
     system is rebooted without syncing the disks.


RETURN VALUES
     The panic() function does not return.

BSD				August 11, 1995 			   BSD

As far as color, black and white tends to be favored over blue and white.


Linux


Mac OS X

78 posted on 07/24/2010 11:45:10 AM PDT by cynwoody
[ Post Reply | Private Reply | To 7 | View Replies ]


To: cynwoody

81 posted on 07/24/2010 11:50:44 AM PDT by Richard Kimball (We're all criminals. They just haven't figured out what some of us have done yet.)
[ Post Reply | Private Reply | To 78 | View Replies ]

Free Republic
Browse · Search
News/Activism
Topics · Post Article


FreeRepublic, LLC, PO BOX 9771, FRESNO, CA 93794
FreeRepublic.com is powered by software copyright 2000-2008 John Robinson